
 AN2722
 SAM L10/L11 Xplained Pro 入门

摘要

本应用笔记旨在借助分别针对 Microchip SAM L10 和 SAM L11 Arm® Cortex®-M23 单片机的 Xplained Pro
评估工具包，开始使用这两款单片机。

Microchip SAM L10 和 SAM L11 Xplained Pro 评估工具包是用于评估 ATSAML10E16A 和

ATSAML11E16A 单片机的硬件平台。

每个工具包均由 Atmel Studio 集成开发平台提供支持，可轻松访问单片机的功能。
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1. 器件相关文档

数据手册

网页：http://www.microchip.com/

文档：SAM L10/L11 系列数据手册，提供了外设说明和电气特性。

芯片勘误

网页：http://www.microchip.com/

文档：SAM L10/L11 Family Silicon Errata and Data Sheet Clarification。
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2. 获取 SAM L10/SAM L11 Xplained Pro 评估工具包

CURRENT
MEASUREMENT

HEADER
DEBUG USB

USER LED0

MCU CURRENT
MEASUREMENT
SELECT JUMPER

I/O CURRENT
MEASUREMENT
SELECT JUMPER

32KHZ CRYSTAL

MIKROBUS HEADER

QTOUCH
BUTTON

EXTENSION 2 HEADER

EXTENSION 1 HEADER

CORTEX DEBUG HEADER
FOR EXTERNAL DEBUGGER

POWER
HEADER

SW0 USER BUTTON RESET BUTTON

ATSAML10E16A OR ATSAML11E16A 

ATECC508A

X32 HEADER

网页： http://www.microchip.com/

欲订购工具包，请访问 Microchip Direct

文档：

• SAM L10/L11 Xplained Pro 用户指南（.pdf）
• SAML10-Xplained-Pro_Design-Documentation（.zip）
• SAML11-Xplained-Pro_Design-Documentation（.zip）

主要特性：

• ATSAML10E16A-AU 或 ATSAML11E16A-AU 单片机

• 一个机械复位按钮

• 一个机械可编程按钮

• 一个 QTouch®按钮

• 一个用户 LED（黄色）
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• 32.768 kHz 晶振

• ATECC508A 加密验证 IC
• 两个 Xplained Pro 扩展插座

• 一个 X32 插座

• 一个 mikroBUS™插座

• 嵌入式调试器

– 在 Atmel Studio 中，使用自动 ID 标识电路板

– 一个状态 LED（黄色）

– 一个电路板电源 LED（绿色）

– 复杂数据类型（包括范围信息）的符号调试

– 编程和调试（包括功率测量）

– 数据网关接口：SPI、I2C 和四个 GPIO
– 虚拟 COM 端口（CDC）

• 采用 Atmel Data Visualizer 的嵌入式电流测量电路，支持数据可视化

• USB 供电

提示： SAM L10/SAM L11 Xplained Pro 用户指南介绍了如何为工具包供电，还介绍了有关电路

板元件、扩展接口和硬件指南的详细信息。
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3. 获取工具
Atmel Studio 7（使用 GCC 编译器）是开始使用 SAM L10/SAM L11 MCU 的首选 IDE。Atmel START 是

生成初始项目的首选用户界面。所有 Atmel START 项目都可以在 Atmel Studio 7、IAR 或 KEIL IDE 中使

用。

Atmel Studio 7
• 网页：Atmel Studio

文档：Atmel Studio 7.0 网络安装程序（.exe）

Atmel Studio 7 是开发和调试 SAM L10/SAM L11 固件的首选 IDE。

Atmel Start
• 网页：Atmel Start

文档：Atmel Start 用户指南：此外，也可使用界面中的 Help（帮助）菜单。

借助 Atmel Start，用户可以一种实用且优化的方式选择和配置软件组件并定制嵌入式应用程序。

 AN2722
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4. 利用 Atmel Studio 7 和 START 开始使用 SAM L10/SAM L11
注： 以下步骤使用 SAM L10 Xplained Pro 作为参考进行描述；不过，使用 SAM L11 Xplained Pro 时可以

执行相同的步骤。

4.1 使用指南

请按照以下步骤开始探索 Atmel Xplained Pro 平台：

1. 下载 Atmel Studio。
2. 安装 Atmel Studio。
3. 启动 Atmel Studio。
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4. 使用 micro-USB 电缆（Standard-A 型转 Micro-AB 型）将工具包连接到计算机。

Xplained Pro MCU 工具包首次连接到计算机时，操作系统将安装软件驱动程序。驱动程序文件支持

32 位和 64 位版本的 Microsoft® Windows® XP、Windows Vista®、Windows 7、Windows 8 和

Windows 10。

Xplained Pro MCU 板上电时，电源 LED（绿色）将亮起，Atmel Studio 将自动检测可能连接的特定

Xplained Pro MCU 和扩展板。Atmel Studio 将提供相关信息的链接，例如数据手册和工具包文档。

注： ATSAML10E16A 和 ATSAML11E16A 器件由板上嵌入式调试器进行编程和调试，因此无需外部

编程器或调试器工具。

图 4-1. Atmel Studio SAM L10/SAM L11 Xplained Pro 简介

3 © 2016 Atmel Corporation
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5. 从 Atmel Studio 启动 Atmel Start：File > New > Atmel Start Example Project（文件 > 新建 > Atmel
Start 示例项目），然后 Atmel Start 将在 Atmel studio 7 中打开。

图 4-2. 在 Atmel Studio 中打开 Atmel Start 示例项目

4 © 2016 Atmel Corporation

Atmel Start 将加载现有的示例列表。

6. 在列表中选择“LED Flasher”示例，然后单击 Open Selected Example（打开选中的示例）。

图 4-3. Atmel start SAM L1x 可用示例列表

5 © 2016 Atmel Corporation

c

c

7. 选择 SAM L10 或 SAM L11 Xplained Pro 板，然后单击 Select board（选择电路板）。
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图 4-4. 电路板选择

6 © 2016 Atmel Corporation
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8. 从 Atmel Start 单击 GENERATE PROJECT（生成项目）生成项目。将显示“My Software
Components”（我的软件组件）窗口。

图 4-5. Atmel Start 项目生成

9 © 2016 Atmel Corporation

9. 将显示以下窗口：请输入项目名称、解决方案和解决方案名称，然后浏览并选择项目位置。单击 OK
（确定），在 Atmel Studio 中打开项目。

图 4-6. Atmel Studio 中的新 Atmel Start 项目导入

10 © 2016 Atmel Corporation

Atmel Studio 将创建该项目。
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10. 按照以下步骤配置调试器/编程器接口：

– 打开项目属性：Project > Properties（项目 > 属性）或<ALT+F7>。
– 单击 Tool（工具）。

– 对于所选调试器/编程器，选择“EDBG ATMLxxx”。

– 对于接口，选择“SWD”。

图 4-7. 编程工具选择

11 © 2016 Atmel Corporation

11. 编译并运行 LED Flasher 应用程序。

– 编译项目：Build > Build Solution（编译 > 编译解决方案）或<F7>。
– 将代码加载到 SAM L10 Xplained Pro 中并开始调试：Debug > Start debugging and break（调

试 > 开始调试并中断）或<ALT+F5>。
– 应用程序已编程，调试器在主函数中中断。

– 运行代码：Debug > Continue（调试 > 继续）或<F5>。
– 该示例通过 Xplained Pro 目标运行。
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5. 利用 Atmel Studio 7 和 Start 开始使用 SAM L11 安全解决方案

5.1 SAM L11 安全概念概述

使用 ATSAM L11 需要熟悉用于 ARMv8-M 器件的 TrustZone®的不同安全功能和概念。

TrustZone 技术是一种片上系统（System-on-Chip，SoC）和 MCU 系统范围的安全方法，支持在 MCU 上

运行安全和非安全代码。它支持创建多个软件安全域，限制只有可信软件才能访问选定存储器、外设和

I/O，而不会影响系统性能。用户可考虑以下部署方法：

• 单开发人员方法（客户 A）
• 双开发人员方法（客户 A + 客户 B）

单开发人员方法包括一个惟一的开发人员（客户 A），负责以下事项：

• 开发、部署和保护安全代码

• 开发和部署非安全代码

在双开发人员方法中，一个开发人员（客户 A）负责开发安全应用程序及其相关的非安全可调用库。安全

应用程序必须加载到 SAM L11 NVM 中并受到保护。

然后，另一个开发人员（客户 B）将在预编程的 SAM L11 上开始非安全应用程序的开发，限制对安全资源

的访问（仅限调用非安全 API）。

 AN2722
利用 Atmel Studio 7 和 Start 开始使用 SAM L11 安全解决方案

© 2018 Microchip Technology Inc. 应用笔记 00002722A_CN-page 13



图 5-1. 单开发人员和双开发人员方法

1- Confidential – For Microchip internal use Only -

Microchip Developer
A End-User 

Blank L11 Final Application

Microchip Developer 
A 

Developer 
B End-User 

Blank L11
Secure Pre-
programmed  
L11 / Modules

Final Application

本文档描述了如何调试由以下两个项目组成的解决方案：

• 安全项目

• 非安全项目

注： 请参见“SAM L11 安全参考指南”应用笔记，其中介绍了 Microchip SAM L11 单片机中可满足大多数

嵌入式系统安全要求的安全功能。
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5.2 使用指南

请按照以下步骤探索 Atmel Xplained Pro 平台：

1. 下载 Atmel Studio。
2. 安装 Atmel Studio。
3. 启动 Atmel Studio。
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4. 使用 micro-USB 电缆（Standard-A 型转 Micro-AB 型）将工具包上的 DEBUG USB 端口连接到计算

机。Xplained Pro MCU 工具包首次连接到计算机时，操作系统将安装软件驱动程序。驱动程序文件

支持 32 位和 64 位版本的 Microsoft® Windows® XP、Windows Vista®、Windows 7、Windows 8 和

Windows 10。

Xplained Pro MCU 板上电时，电源 LED（绿色）将亮起。Atmel Studio 将自动检测连接的特定

Xplained Pro MCU 和扩展板。Atmel Studio 将提供相关信息，例如数据手册和工具包文档。

ATSAML11E16A 器件由板上嵌入式调试器进行编程和调试，因此无需外部编程器或调试器工具。

图 5-2. Atmel Studio SAM L11 Xplained Pro 简介

14 © 2016 Atmel Corporation
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5. 从 Atmel Studio 启动 Atmel Start 以打开安全应用程序项目：File > New > Atmel Start Example
Project，然后 Atmel Start 将直接在 Atmel studio 中打开。

图 5-3. 在 Atmel Studio 中打开新的 Atmel Start 示例项目

4 © 2016 Atmel Corporation

注： 几秒钟后，将显示示例列表。

6. 从示例列表中选择安全项目的“TrustZone 入门示例”（TZ-GetStart-S），然后单击 OPEN
SELECTED EXAMPLE。
图 5-4. TrustZone 入门 SAM L11 安全项目示例选择

16 © 2016 Atmel Corporation
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7. 从 Atmel Start 生成项目以在 Atmel Studio 中打开。打开项目后，单击 GENERATE PROJECT。
图 5-5. Atmel Start 安全项目概述和生成

17 © 2016 Atmel Corporation
8. 将显示以下“New Atmel Start Project”（新建 Atmel Start 项目）窗口。

图 5-6. 安全项目导入视图
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9. 修改以下项目信息：

– 输入新的项目名称。

– 单击 Browse（浏览）选择项目存放位置。

– 解决方案：选择 Create New Solution（创建新的解决方案）。

– 解决方案名称：输入 TrustZoneGettingStarted。
– 单击 OK，在 Atmel Studio 中打开项目。

图 5-7. 修改项目信息

 AN2722
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10. 要在 Atmel Studio 解决方案资源管理器中查看项目：View > Solution Explorer（视图 > 解决方案资

源管理器）或<CTRL+ALT+L>。
图 5-8. 显示安全项目的 Atmel Studio 解决方案资源管理器

19 © 2016 Atmel Corporation

目前，TrustZoneGettingStarted 解决方案仅包括 SecureProject。
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11. 要编译“TrustZoneGettingStarted”安全应用程序，需编译项目：Build > Build Solution 或<F7>。
由于该项目的当前编译可以生成未来非安全应用程序中使用的安全库网关，因此十分重要。

图 5-9. 安全项目编译输出窗口

21 © 2016 Atmel Corporation
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编译了安全应用程序，并在 SecureProject/Debug 文件夹中生成了安全库网关：

图 5-10. 编译产生的安全库文件

 AN2722
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12. 在 Atmel Studio 中关闭 Atmel Start 窗口。

13. 重新打开一个新的 Atmel Start 示例项目以创建非安全应用程序：

– File > New > Atmel Start Example Project。
– Atmel Start 将直接在 Atmel studio 中打开。

图 5-11. 在 Atmel Studio 中打开新的 Atmel Start 示例项目

4 © 2016 Atmel Corporation

14. 从现有示例列表中选择非安全项目的“TrustZone 入门示例”（TZ-GetStart-NS），然后单击 OPEN
SELECTED EXAMPLE。
图 5-12. TrustZone 入门 SAM L11 非安全项目示例选择

25 © 2016 Atmel Corporation
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15. 从 Atmel Start 生成项目以在 Atmel Studio 中打开，加载完成后，单击 GENERATE PROJECT。
图 5-13. Atmel Start 非安全项目概述和生成

26 © 2016 Atmel Corporation
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16. 将显示以下“New Atmel Start Project”窗口。

图 5-14. 非安全项目导入窗口
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17. 修改项目信息，如下所示：

图 5-15. 新建 Atmel Start 项目

26 © 2016 Atmel Corporation

– 项目名称：将项目名称重命名为“NonSecure Project”。

– 位置：保持与安全应用程序项目相同的位置。

– 解决方案：选择 Add to Solution（添加到解决方案）。

– 解决方案名称：保持与安全项目相同的解决方案名称：TrustZoneGettingStarted。
– 确保现在不要单击 OK 按钮。

重要： 确保通过单击 Add As Link（添加为链接）选择添加选项。

用户需要为非安全项目导入完成以下步骤：

– 添加所需的安全项目模板头（Secure Project Veneer Header）文件，以添加用于在安全应用

程序和非安全应用程序之间进行通信的模板函数。安全项目模板头文件位于

SecureProjectFolder/trustzone 文件夹中。在此示例中，此文件名为

trustzone_veneer.h。
– 添加所需的安全项目导出库（Secure Project Export Library）文件，以添加包含用于在安全应

用程序和非安全应用程序之间进行通信的安全函数的编译库。安全项目导出库文件位于

SecureProjectFolder/debug 文件夹中。在此示例中，此文件名为

libsecure_gateway_veneer.lib。
– 添加所需的非安全项目链接描述文件，以管理应用程序编程的存储器分配（非安全和安全部

分）。非安全项目链接描述文件位于 SecureProjectFolder/Device_Startup 文件夹中。在此示

例中，此文件名为 saml11_nonsecure.ld。
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图 5-16. New Atmel Start Project 窗口

27 © 2016 Atmel Corporation

– 单击 OK，在 Atmel Studio 中打开项目。
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18. 要使用 Atmel Studio 解决方案资源管理器（Atmel Studio Solution Explorer）查看此项目，请选择

View/Solution Explorer 或按下<CTRL+ALT+L>。
解决方案 TrustZoneGettingStarted 现在包括两个项目。这两个项目如下图所示。

– SecureProject
– NonSecureProject

图 5-17. 显示安全和非安全项目的 Atmel Studio 解决方案资源管理器

28 © 2016 Atmel Corporation
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19. 配置非安全项目调试器/编程器接口。打开项目属性，然后执行以下操作：Project > Properties 或按

下<ALT+F7>。
20. 单击 Tool。

– 对于所选调试器/编程器，选择“EDBG ATMLxxx”。

– 对于接口，选择“SWD”。

图 5-18. 非安全项目的编程工具选择

29 © 2016 Atmel Corporation

21. 编译 NonSecureProject：要编译项目：Build > Build Solution 或按下<F7>。检查并确认未报告任何

错误。

图 5-19. 非安全项目编译输出窗口

30 © 2016 Atmel Corporation
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22. 配置 SecureProject 和 NonSecureProject 以进行交叉调试。

– 在 Solution Explorer 窗口中，右键单击 SecureProject 文件并选择 Properties。
图 5-20. 如何在 Atmel Studio 中访问项目属性

31 © 2016 Atmel Corporation
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– 在 SecureProject 属性窗口中，单击 Advanced（高级）。

图 5-21. Advanced 项目属性选项卡

32 © 2016 Atmel Corporation

– 单击 Add（添加）以将 NonSecureProject.elf 文件添加到 SecureProject 附加模块。

NonSecureProject.elf 是一个位于 NonSecureProjectFolder/Debug 文件夹的编译文件。

图 5-22. .elf 文件选择

1

2

3
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NonSecureProject.elf 文件现在访问部分 SecureProject 附加模块，如下所示：

图 5-23. NonSecureProject 属性窗口

34 © 2016 Atmel Corporation

– 要完成此步骤，请保存当前属性：File > SaveSecureProject。

– 在 Solution Explorer 窗口中，右键单击 NonSecureProject 文件并选择 Properties。
– 在 NonSecureProject 属性窗口中，单击 Advanced。
– 单击 Add 以将 SecureProject.elf 文件添加到 NonSecureProject 附加模块。

注： SecureProject.elf 是一个位于 SecureProjectFolder/debug 文件夹的编译文件。

SecureProject.elf 文件成为 SecureProject 附加模块的访问部分，如下所示：

图 5-24. NonSecureProject 属性窗口

35 © 2016 Atmel Corporation

– 要完成此步骤，请执行以下操作以保存当前属性：File > SaveSecureProject。
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23. 要设置断点以调试完整的 TrustZone 解决方案，请按以下步骤操作：

– 在 NonSecureProject 中设置一个断点。

– 在 Solution Explorer 窗口中部署 NonSecureProject 文件，然后打开 main.c 文件。

– 双击相关行以添加断点。

图 5-25. Atmel Studio IDE 概述：断点位置

36 © 2016 Atmel Corporation

在这种情况下，将断点置于调用非安全可调用函数 1（nsc_func_plus3）所在的行处。该函数在

编译 SecureProject 后生成的 libsecure_gateway_veneer.lib文件中进行了声明。

在模板（安全网关）中完成对安全函数 func_plus3的调用，在 SecureProject 的 main.c文件中

完成声明。

– 在安全网关 trustzone_veneer.c文件的 return func_plus3(x);行处设置断点。
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图 5-26. Atmel Studio IDE 概述：到达安全网关模板中的断点
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– 在 SecureProject main.c文件的 func_plus3声明处设置断点。

图 5-27. Atmel Studio IDE 概述：到达安全项目中的断点

37 © 2016 Atmel Corporation

 AN2722
利用 Atmel Studio 7 和 Start 开始使用 SAM L11 安全解决方案

© 2018 Microchip Technology Inc. 应用笔记 00002722A_CN-page 35



– 调试项目并查看非安全项目中的断点，然后在安全项目中按以下步骤操作：

• 单击 或按下<F5>开始并执行新的调试会话。执行将在 NonSecureProject 中的第一个

断点处暂停。

图 5-28. 调试会话窗口

38 © 2016 Atmel Corporation

– 再次单击 或按下<F5>以继续调试会话。执行将在安全网关

（trustzone_veneer.c）中的第二个断点处暂停。

– 再次单击 或按下<F5>以继续调试会话。执行将在 SecureProject 中的第三个断

点处暂停。

图 5-29. 调试会话窗口

39 © 2016 Atmel Corporation

 AN2722
利用 Atmel Studio 7 和 Start 开始使用 SAM L11 安全解决方案

© 2018 Microchip Technology Inc. 应用笔记 00002722A_CN-page 36



注： 现在，可以不受任何限制地对安全和非安全项目进行调试。
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Microchip 网站

Microchip 网站 http://www.microchip.com/为客户提供在线支持。客户可通过该网站方便地获取文件和信

息。只要使用常用的互联网浏览器即可访问，网站提供以下信息：

• 产品支持——数据手册和勘误表、应用笔记和示例程序、设计资源、用户指南以及硬件支持文档、最

新的软件版本以及归档软件

• 一般技术支持——常见问题（FAQ）、技术支持请求、在线讨论组以及 Microchip 顾问计划成员名单

• Microchip 业务——产品选型和订购指南、最新 Microchip 新闻稿、研讨会和活动安排表、Microchip
销售办事处、代理商以及工厂代表列表

变更通知客户服务

Microchip 的变更通知客户服务有助于客户了解 Microchip 产品的最新信息。注册客户可在他们感兴趣的某

个产品系列或开发工具发生变更、更新、发布新版本或勘误表时，收到电子邮件通知。

欲注册，请登录 Microchip 网站 http://www.microchip.com/。在“支持”（Support）下，点击“变更通知

客户”（Customer Change Notification）服务后按照注册说明完成注册。

客户支持

Microchip 产品的用户可通过以下渠道获得帮助：

• 代理商或代表

• 当地销售办事处

• 应用工程师（FAE）
• 技术支持

客户应联系其代理商、代表或应用工程师（FAE）寻求支持。当地销售办事处也可为客户提供帮助。本文

档后附有销售办事处的联系方式。

也可通过以下网站获得技术支持： http://www.microchip.com/support

Microchip 器件代码保护功能

请注意以下有关 Microchip 器件代码保护功能的要点：

• Microchip 的产品均达到 Microchip 数据手册中所述的技术指标。

• Microchip 确信：在正常使用的情况下，Microchip 系列产品是当今市场上同类产品中最安全的产品

之一。

• 目前，仍存在着恶意、甚至是非法破坏代码保护功能的行为。就我们所知，所有这些行为都不是以

Microchip 数据手册中规定的操作规范来使用 Microchip 产品的。这样做的人极可能侵犯了知识产

权。

• Microchip 愿意与关心代码完整性的客户合作。

• Microchip 或任何其他半导体厂商均无法保证其代码的安全性。代码保护并不意味着我们保证产品是

“牢不可破”的。

代码保护功能处于持续发展中。Microchip 承诺将不断改进产品的代码保护功能。任何试图破坏 Microchip
代码保护功能的行为均可视为违反了《数字器件千年版权法案（Digital Millennium Copyright Act）》。如
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果这种行为导致他人在未经授权的情况下，能访问您的软件或其他受版权保护的成果，您有权依据该法案

提起诉讼，从而制止这种行为。

法律声明

本出版物中所述的器件应用信息及其他类似内容仅为您提供便利，它们可能由更新之信息所替代。确保应

用符合技术规范，是您自身应负的责任。Microchip 对这些信息不作任何明示或暗示、书面或口头、法定或

其他形式的声明或担保，包括但不限于针对其使用情况、质量、性能、适销性或特定用途的适用性的声明

或担保。Microchip 对因这些信息及使用这些信息而引起的后果不承担任何责任。如果将 Microchip 器件用

于生命维持和/或生命安全应用，一切风险由买方自负。买方同意在由此引发任何一切伤害、索赔、诉讼或

费用时，会维护和保障 Microchip 免于承担法律责任，并加以赔偿。除非另外声明，否则在 Microchip 知识

产权保护下，不得暗中或以其他方式转让任何许可证。

商标

Microchip 的名称和徽标组合、Microchip 徽标、AnyRate、AVR、AVR 徽标、AVR Freaks、BitCloud、
chipKIT、chipKIT 徽标、CryptoMemory、CryptoRF、dsPIC、FlashFlex、flexPWR、Heldo、JukeBlox、
KeeLoq、Kleer、LANCheck、LINK MD、maXStylus、maXTouch、MediaLB、megaAVR、MOST、
MOST 徽标、MPLAB、OptoLyzer、PIC、picoPower、PICSTART、PIC32 徽标、Prochip Designer、
QTouch、SAM-BA、SpyNIC、SST、SST 徽标、SuperFlash、tinyAVR、UNI/O 和 XMEGA 是 Microchip
Technology Incorporated 在美国和其他国家或地区的注册商标。

ClockWorks、The Embedded Control Solutions Company、EtherSynch、Hyper Speed Control、
HyperLight Load、IntelliMOS、mTouch、Precision Edge 和 Quiet-Wire 为 Microchip Technology
Incorporated 在美国的注册商标。

Adjacent Key Suppression、AKS、Analog-for-the-Digital Age、Any Capacitor、AnyIn、AnyOut、
BodyCom、CodeGuard、CryptoAuthentication、CryptoAutomotive、CryptoCompanion、
CryptoController、dsPICDEM、dsPICDEM.net、Dynamic Average Matching、DAM、ECAN、

EtherGREEN、In-Circuit Serial Programming、ICSP、INICnet、Inter-Chip Connectivity、JitterBlocker、
KleerNet、KleerNet 徽标、memBrain、Mindi、MiWi、motorBench、MPASM、MPF、MPLAB Certified
徽标、MPLIB、MPLINK、MultiTRAK、NetDetach、Omniscient Code Generation、PICDEM、

PICDEM.net、PICkit、PICtail、PowerSmart、PureSilicon、QMatrix、REAL ICE、Ripple Blocker、SAM-
ICE、Serial Quad I/O、SMART-I.S.、SQI、SuperSwitcher、SuperSwitcher II、Total Endurance、
TSHARC、USBCheck、VariSense、ViewSpan、WiperLock、Wireless DNA 和 ZENA 为 Microchip
Technology Incorporated 在美国和其他国家或地区的商标。

SQTP 为 Microchip Technology Inc.在美国的服务标记。

Silicon Storage Technology 为 Microchip Technology Inc.在除美国外的国家或地区的注册商标。

GestIC 是 Microchip Technology Inc.的子公司 Microchip Technology Germany II GmbH & Co. KG 在除美

国外的国家或地区的注册商标。

在此提及的所有其他商标均为各持有公司所有。

© 2018, Microchip Technology Incorporated 版权所有。

ISBN： 978-1-5224-3833-5
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DNV 认证的质量管理体系

ISO/TS 16949
Microchip 位于美国亚利桑那州 Chandler 和 Tempe 与位于俄勒冈州 Gresham 的全球总部、设计和晶圆生

产厂及位于美国加利福尼亚州和印度的设计中心均通过了 ISO/TS-16949:2009 认证。Microchip 的 PIC®

MCU 和 dsPIC® DSC、KEELOQ®
跳码器件、串行 EEPROM、单片机外设、非易失性存储器及模拟产品严

格遵守公司的质量体系流程。此外，Microchip 在开发系统的设计和生产方面的质量体系也已通过了 ISO
9001:2000 认证。
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美洲 亚太地区 亚太地区 欧洲

公司总部

2355 West Chandler Blvd.
Chandler, AZ 85224-6199
电话：1-480-792-7200
传真：1-480-792-7277
技术支持：

http://www.microchip.com/
support
网址：

www.microchip.com
亚特兰大

德卢斯，乔治亚州

电话：1-678-957-9614
传真：1-678-957-1455
奥斯汀，德克萨斯州

电话：1-512-257-3370
波士顿

韦斯特伯鲁，马萨诸塞州

电话：1-774-760-0087
传真：1-774-760-0088
芝加哥

艾塔斯卡，伊利诺伊州

电话：1-630-285-0071
传真：1-630-285-0075
达拉斯

艾迪生，德克萨斯州

电话：1-972-818-7423
传真：1-972-818-2924
底特律

诺维，密歇根州

电话：1-248-848-4000
休斯敦，德克萨斯州

电话：1-281-894-5983
印第安纳波利斯

诺布尔斯维尔，印第安纳州

电话：1-317-773-8323
传真：1-317-773-5453
电话：1-317-536-2380
洛杉矶

米申维耶霍，加利福尼亚州

电话：1-949-462-9523
传真：1-949-462-9608
电话：1-951-273-7800
罗利，北卡罗来纳州

电话：1-919-844-7510
纽约，纽约州

电话：1-631-435-6000
圣何塞，加利福尼亚州

电话：1-408-735-9110
电话：1-408-436-4270
加拿大 - 多伦多

电话：1-905-695-1980
传真：1-905-695-2078

中国 - 北京
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中国 - 成都
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中国 - 上海
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电话：86-24-2334-2829
中国 - 深圳

电话：86-755-8864-2200
中国 - 苏州

电话：86-186-6233-1526
中国 - 武汉

电话：86-27-5980-5300
中国 - 西安

电话：86-29-8833-7252
中国 - 厦门

电话：86-592-2388138
中国 - 香港特别行政区

电话：852-2943-5100
中国 - 珠海

电话：86-756-3210040
台湾地区 - 高雄
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电话：886-3-577-8366
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印度 - 浦那

电话：91-20-4121-0141
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电话：82-2-554-7200
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